VS:AngDialog: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:25, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function AngDialog displays a dialog box which requests the user to enter an angle value. The dialog automatically screens for valid numeric input, and will accept supported angle formats.

FUNCTION AngDialog(
request :STRING;
default :STRING) : REAL;
def vs.AngDialog(request, default):
    return REAL

Parameters

request STRING Dialog user prompt string.
default STRING Default value for input field.

Example

VectorScript

AngleValue := AngDialog('Enter an angle value:', '0d');

Python

AngleValue = vs.AngDialog('Enter an angle value:', '0d')

Version

Availability: from All Versions