VS:AngBVec

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the positive angle between the two specified vectors, in the range of 0~180 degrees.

When used with 3D vectors, the angle returned will be in a plane defined by the two vectors.

FUNCTION AngBVec(
v1 :VECTOR;
v2 :VECTOR) : REAL;
def vs.AngBVec(v1, v2):
    return REAL

Parameters

v1 VECTOR First vector to be compared.
v2 VECTOR Second vector to be compared.

Return Value

Returns a REAL value which is the angle (in degrees) between the two vectors.

Remarks

This is precisely what Vec2Ang does, except that Vec2Ang uses the X axis as the other vector.

(Orso, 2010 Dec. 22) See vector diagrams on Vectorlab: what AngBVec represents.

Example

VectorScript

PROCEDURE Example;
VAR
pt1, pt2, pt3, pt4 :VECTOR;
BEGIN
GetPt(pt1.x, pt1.y);
GetPtL(pt1.x, pt1.y, pt2.x, pt2.y);
GetPtL(pt2.x, pt2.y, pt3.x, pt3.y);
MoveTo(pt1.x, pt1.y);
LineTo(pt2.x, pt2.y);
LineTo(pt3.x, pt3.y);
pt4 := (pt1 + pt3) / 2;
TextOrigin(pt4.x, pt4.y);
CreateText(Concat(AngBVec(pt1 - pt2, pt3 - pt2)));
END;
RUN(Example);

Python


Version

Availability: from All Versions