VS:AlignItemEdge

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Aligns the specified control item with other items having the same edge and alignment id values. To align several control items, call this function once for each item to be aligned using a common alignment id value.

Table - Alignment Options
Index Alignment Edge
1 Right
2 Bottom
3 Left
Index Alignment Mode
0 Resize control items
1 Shift control items


Right alignment of objects will use the object with the minimum pixel value as the alignment baseline. Bottom and left alignment of objects will use the object with the maximum pixel value as the alignment baseline.

PROCEDURE AlignItemEdge(
dialogID :LONGINT;
itemID :LONGINT;
whichEdge :LONGINT;
alignID :INTEGER;
alignMode :INTEGER);
def vs.AlignItemEdge(dialogID, itemID, whichEdge, alignID, alignMode):
    return None

Parameters

dialogID LONGINT The index of the dialog layout being defined.
itemID LONGINT The index of the control item to be aligned.
whichEdge LONGINT The control edge to be aligned.
alignID INTEGER An arbitrary number used to identify the items to be aligned together.
alignMode INTEGER Alignment mode of the operation

Remarks

Aligns layout items with the same edge and alignID. whichEdge: 1=right, 2=bottom, 3=left; alignMode: resize=0, shift=1

Right aligned objects are lined up with the object with the minimum pixel value. Bottom and left aligned objects are lined up on the maximum pixel value.[DWD 1/20/00]

Example

{aligns all items with the positioning ID of 99}
AlignItemEdge(lEditID, 4, 1, 99, 0);
AlignItemEdge(lEditID, 6, 1, 99, 0);

Version

Availability: from VectorWorks 9.0