VS:AlertQuestionDontShowAgain/ja: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision: 2014J VS Reference A take 3)
 
(6 intermediate revisions by the same user not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVS/ja|specific=}}
{{LocationMain|category=LocationVS/ja|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 6: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
二度と表示しないオプション付きのユーザの決定を入力することができる警告ダイアログ表示する。<BR>
二度と表示しないオプション付きのユーザの決定を入力することができる警告ダイアログ表示します。<BR>
<BR>
'arrOptions' の型は ARRAY [1..3] OF STRING;<BR>
'arrOptions' の型は ARRAY [1..3] OF STRING;<BR>
arrOpt[1] - チェックボックスの値を保存するための保存設定のカテゴリー<BR>
arrOpt[1] - チェックボックスの値を保存するための保存設定のカテゴリー<BR>
Line 104: Line 102:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
関連関数:
VS Functions:
[[VS:AlertInform]]  
[[VS:AlertInform]]  
| [[VS:AlertQuestion]]  
| [[VS:AlertQuestion]]  
Line 113: Line 111:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
利用可能バージョン: Vectorworks 2010
Availability: from Vectorworks 2010


</version>
</version>

Latest revision as of 01:37, 16 January 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

二度と表示しないオプション付きのユーザの決定を入力することができる警告ダイアログ表示します。

'arrOptions' の型は ARRAY [1..3] OF STRING;
arrOpt[1] - チェックボックスの値を保存するための保存設定のカテゴリー
arrOpt[2] - チェックボックスの値を保存するための保存設定の要素
arrOpt[3] - 「つねに選択した動作を行う」チェックボックスの文字列

FUNCTION AlertQuestionDontShowAgain(
question :STRING;
advice :STRING;
defaultButton :INTEGER;
OKOverrideText :STRING;
CancelOverrideText :STRING;
customButtonAText :STRING;
customButtonBText :STRING;
arrOptions :ARRAY) : INTEGER;
def vs.AlertQuestionDontShowAgain(question, advice, defaultButton, OKOverrideText, CancelOverrideText, customButtonAText, customButtonBText, arrOptions):
    return INTEGER

Parameters

question STRING 本文として表示する文字列
advice STRING 本文の下に小さなフォントで注釈文として表示する文字列
defaultButton INTEGER デフォルトで選択されるボタンの番号
OKOverrideText STRING OKボタンに表示する文字列
CancelOverrideText STRING キャンセルボタンに表示する文字列
customButtonAText STRING Aボタンに表示する文字列
customButtonBText STRING Bボタンに表示する文字列
arrOptions ARRAY アラートオブション[1][2][3]

Return Value

選択されたボタンの番号(0,1,2,3)

Example

PROCEDURE Example;

VAR
	result :INTEGER;
	arrayText : ARRAY[1..3] OF STRING;

BEGIN
	arrayText[1] := 'DontShowDialogAgainCategory';
	arrayText[2] := 'DontShowDialogAgainItem'; {Should be unique for every AlertQuestionDontShowAgain}
	arrayText[3] := '';

	result := AlertQuestionDontShowAgain('Do you want to continue?', '', 0, 'Yes', 'No', '', '', arrayText);
END;

RUN(Example);

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:AlertInform | VS:AlertQuestion | VS:AlertCritical | VS:AlertInformDontShowAgain

VS Functions:

[[VS:AlertInform]] | [[VS:AlertQuestion]] | [[VS:AlertCritical]]

| [[VS:AlertInformDontShowAgain]]