VS:AlertQuestion/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ユーザの決定を入力することができる警告ダイアログを表示します。

例えば、元に戻すことのできない操作を実行する前などに表示します。
ダイアログに表示する文章を質問形式にすることができます。

FUNCTION AlertQuestion(
question :STRING;
advice :STRING;
defaultButton :INTEGER;
OKOverrideText :STRING;
CancelOverrideText :STRING;
customButtonAText :STRING;
customButtonBText :STRING) : INTEGER;
def vs.AlertQuestion(question, advice, defaultButton, OKOverrideText, CancelOverrideText, customButtonAText, customButtonBText):
    return INTEGER

Parameters

question STRING 本文として表示する文字列
advice STRING 本文の下に小さなフォントで注釈文として表示する文字列
defaultButton INTEGER デフォルトで選択されるボタンの番号
OKOverrideText STRING OKボタンに表示する文字列
CancelOverrideText STRING キャンセルボタンに表示する文字列
customButtonAText STRING Aボタンに表示する文字列
customButtonBText STRING Bボタンに表示する文字列

Return Value

返り値

0:キャンセルボタンがクリックされました。
1:OKボタンがクリックされました。
2:ボタンAがクリックされました。
3:ボタンBがクリックされました。

Example

PROCEDURE Example;

VAR
	result :INTEGER;

BEGIN
   result := AlertQuestionDontShowAgain('Do you want to continue?', '', 0, 'Yes', 'No', '', '');
END;

RUN(Example);

Version

利用可能バージョン: VectorWorks12.0

See Also

関連関数:

VS:AlertInform | VS:AlertCritical | VS:AlertInformDontShowAgain | VS:AlertQuestionDontShowAgain

関連関数:

[[VS:AlertInform]] | [[VS:AlertCritical]] | [[VS:AlertInformDontShowAgain]]

| [[VS:AlertQuestionDontShowAgain]]