VS:AlertInformDontShowAgain/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

二度と表示しないオプション付きのアラートダイアログ表示します。

'arrOptions' の型は ARRAY [1..3] OF STRING;
arrOpt[1] - チェックボックスの値を保存するための保存設定のカテゴリー
arrOpt[2] - チェックボックスの値を保存するための保存設定の要素
arrOpt[3] - 「二度とこのダイアログを表示しない」チェックボックスの文字列

PROCEDURE AlertInformDontShowAgain(
text :STRING;
advice :STRING;
minorAlert :BOOLEAN;
arrOptions :ARRAY);
def vs.AlertInformDontShowAgain(text, advice, minorAlert, arrOptions):
    return None

Parameters

text STRING 本文として表示する文字列
advice STRING 本文の下に小さなフォントで注釈文として表示する文字列
minorAlert BOOLEAN アラートの重要度(TRUE:低/FALSE:高)
arrOptions ARRAY ARRAY [1..3] OF STRING;
arrOpt[1] - チェックボックスの値を保存するための保存設定のカテゴリー
arrOpt[2] - チェックボックスの値を保存するための保存設定の要素
arrOpt[3] - 「二度とこのダイアログを表示しない」チェックボックスの文字列

Example

PROCEDURE Example;

VAR
	result :INTEGER;
	arrayText : ARRAY[1..3] OF STRING;

BEGIN
	arrayText[1] := 'DontShowDialogAgainCategory';
	arrayText[2] := 'DontShowDialogAgainItem'; {Should be unique for every AlertInformDontShowAgain}
	arrayText[3] := '';

	AlertInformDontShowAgain('This is an invalid item.', '', false, arrayText);
END;

RUN(Example);

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:AlertInform | VS:AlertQuestion | VS:AlertCritical | VS:AlertQuestionDontShowAgain

VS Functions:

[[VS:AlertInform]] | [[VS:AlertQuestion]] | [[VS:AlertCritical]]

| [[VS:AlertQuestionDontShowAgain]]