VS:AlertInformDontShowAgain: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 76: Line 76:
<code lang="py">
<code lang="py">
def Example():
def Example():
arrayText = []
arrayText = ('DontShowDialogAgainCategory',
arrayText.append('DontShowDialogAgainCategory')
'DontShowDialogAgainItem', #{Should be unique for every AlertInformDontShowAgain}
arrayText.append('DontShowDialogAgainItem') #{Should be unique for every AlertInformDontShowAgain}
'')
arrayText.append('')


AlertInformDontShowAgain('This is an invalid item.', '', False, arrayText);
        # python uses a tuple
vs.AlertInformDontShowAgain('This is an invalid item.', '', False, arrayText);
Example()
Example()
</code>
</code>

Latest revision as of 15:21, 3 July 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Displays an alert dialog which provides the user an information about the result of a command with an option to not show the dialog again. It offers no user choices.


The parameter 'arrOptions' is of type ARRAY [1..3] OF STRING;
arrOpt[1] - Saved setting category to save checkbox value
arrOpt[2] - Saved setting item to save checkbox value
arrOpt[3] - Specify the string to use in overriding the default 'Dont show this dialog again' checkbox string

PROCEDURE AlertInformDontShowAgain(
text :STRING;
advice :STRING;
minorAlert :BOOLEAN;
arrOptions :ARRAY);
def vs.AlertInformDontShowAgain(text, advice, minorAlert, arrOptions):
    return None

Parameters

text STRING The information to be displayed.
advice STRING The text to be added in a smaller font under the main information message.
minorAlert BOOLEAN The severity of the alert: minor(true) or major(false).
arrOptions ARRAY ARRAY [1..3] OF STRING;

Remarks

Created by TTF 1/9/2009

Example

VectorScript

PROCEDURE Example;
VAR
	result :INTEGER;
	arrayText : ARRAY[1..3] OF STRING;

BEGIN
	arrayText[1] := 'DontShowDialogAgainCategory';
	arrayText[2] := 'DontShowDialogAgainItem'; {Should be unique for every AlertInformDontShowAgain}
	arrayText[3] := '';

	AlertInformDontShowAgain('This is an invalid item.', '', false, arrayText);
END;
RUN(Example);

Python

def Example():
	arrayText = ('DontShowDialogAgainCategory',
				'DontShowDialogAgainItem', #{Should be unique for every AlertInformDontShowAgain}
				'')

        # python uses a tuple
	vs.AlertInformDontShowAgain('This is an invalid item.', '', False, arrayText);
Example()

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:AlertInform | VS:AlertQuestion | VS:AlertCritical | VS:AlertQuestionDontShowAgain

VS Functions:

[[VS:AlertInform]] | [[VS:AlertQuestion]] | [[VS:AlertCritical]]

| [[VS:AlertQuestionDontShowAgain]]