VS:AlertInform

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Displays an alert dialog which provides the user an information about the result of a command. It offers no user choices.

PROCEDURE AlertInform(
text :STRING;
advice :STRING;
minorAlert :BOOLEAN);
def vs.AlertInform(text, advice, minorAlert):
    return None

Parameters

text STRING The information to be displayed.
advice STRING The text to be added in a smaller font under the main information message.
minorAlert BOOLEAN The severity of the alert: minor(true) or major(false).

Remarks

Created by 1/18/2005

Example

VectorScript

PROCEDURE Example;
BEGIN
AlrtDialog('AlrtDialog');
AlertInform('AlertInform', 'advice', FALSE);
AlertCritical('AlertCritical', 'advice');
Message(YNDialog('YNDialog'));
Message(AlertQuestion('question', 'advice', 1, 'ok', 'cancel', 'a', 'b'));
END;
RUN(Example);

Python

def Example():
	vs.AlrtDialog('AlrtDialog')
	vs.AlertInform('AlertInform', 'advice', False)
	vs.AlertCritical('AlertCritical', 'advice')	
	vs.Message(vs.YNDialog('YNDialog'))
	vs.Message(vs.AlertQuestion('question', 'advice', 1, 'ok', 'cancel', 'a', 'b'))
Example()

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:AlertQuestion | VS:AlertCritical

VS Functions:

[[VS:AlertQuestion]]

| [[VS:AlertCritical]]