VS:AlertInform

From Vectorworks Developer
Revision as of 21:51, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Displays an alert dialog which provides the user an information about the result of a command. It offers no user choices.

PROCEDURE AlertInform(
text :STRING;
advice :STRING;
minorAlert :BOOLEAN);
def vs.AlertInform(text, advice, minorAlert):
    return None

Parameters

text STRING The information to be displayed.
advice STRING The text to be added in a smaller font under the main information message.
minorAlert BOOLEAN The severity of the alert: minor(true) or major(false).

Remarks

Created by 1/18/2005

Example

VectorScript

PROCEDURE Example;
BEGIN
AlrtDialog('AlrtDialog');
AlertInform('AlertInform', 'advice', FALSE);
AlertCritical('AlertCritical', 'advice');
Message(YNDialog('YNDialog'));
Message(AlertQuestion('question', 'advice', 1, 'ok', 'cancel', 'a', 'b'));
END;
RUN(Example);

Python

def Example():
	vs.AlrtDialog('AlrtDialog')
	vs.AlertInform('AlertInform', 'advice', False)
	vs.AlertCritical('AlertCritical', 'advice')	
	vs.Message(vs.YNDialog('YNDialog'))
	vs.Message(vs.AlertQuestion('question', 'advice', 1, 'ok', 'cancel', 'a', 'b'))
Example()

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:AlertQuestion | VS:AlertCritical

VS Functions:

[[VS:AlertQuestion]]

| [[VS:AlertCritical]]