VS:AddWSColumnOperator: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 50: Line 50:
All operators = -1<BR>
All operators = -1<BR>
Sort operator = 0<BR>
Sort operator = 0<BR>
Summarize operator = 1</remark>
Summarize operator = 1<BR>
Add operator = 2</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 08:37, 24 June 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds database column operator to specified column.

PROCEDURE AddWSColumnOperator(
worksheet :HANDLE;
databaseRow :INTEGER;
column :INTEGER;
operatorType :INTEGER);
def vs.AddWSColumnOperator(worksheet, databaseRow, column, operatorType):
    return None

Parameters

worksheet HANDLE Handle to worksheet.
databaseRow INTEGER Database row to be queried.
column INTEGER Column to be queried.
operatorType INTEGER Operator type.

Remarks

Operator type constants:

All operators = -1
Sort operator = 0
Summarize operator = 1
Add operator = 2

Version

Availability: from Vectorworks 2012