VS:AddToPluginStyle: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (fixed typo)
m (1 revision)
 
(One intermediate revision by the same user not shown)
Line 43: Line 43:
<return>
<return>
TRUE if the item was added to the plug-in style.<BR>
TRUE if the item was added to the plug-in style.<BR>
FALSE if the symbol definition does not contain a plug-in style or the style alread contains an item by the given name.</return>
FALSE if the symbol definition does not contain a plug-in style or the style alread contrains an item by the given name.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 18:51, 7 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds a new item to a plug-in style map.

FUNCTION AddToPluginStyle(
hSymDef :HANDLE;
itemName :STRING;
styleType :INTEGER) : BOOLEAN;
def vs.AddToPluginStyle(hSymDef, itemName, styleType):
    return BOOLEAN

Parameters

hSymDef HANDLE Handle to a symbol definition containing a plug-in style.
itemName STRING Name of new item to add.
styleType INTEGER Style type for new item. 0 sets the item to By Instance 1 sets the item to By style.

Return Value

TRUE if the item was added to the plug-in style.

FALSE if the symbol definition does not contain a plug-in style or the style alread contrains an item by the given name.

Version

Availability: from Vectorworks 2017