VS:AddTileGeometryObject

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds the specified object to the specified tile resource.

FUNCTION AddTileGeometryObject(
tileHandle :HANDLE;
objectHandle :HANDLE) : BOOLEAN;
def vs.AddTileGeometryObject(tileHandle, objectHandle):
    return BOOLEAN

Parameters

tileHandle HANDLE The handle to the tile resource.
objectHandle HANDLE The handle to the object to add.

Return Value

TRUE if a valid object was successfully added; FALSE otherwise.

Example

return := AddTileGeometryGroup(tileHandle, objectHandle);

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:CreateTile | VS:ShowEditTileDialog | VS:ShowEditTileSettingsDialog | VS:ShowNewTileDialog | VS:GetTileGeometryGroup | VS:BeginGroupN | VS:AddTileGeometryObject | VS:GetTileGroupParent | VS:IsTileGroupContainedObject | VS:GetTileBackgroundColor | VS:SetTileBackgroundColor | VS:GetTileRepetitionPoint | VS:SetTileRepetitionPoint | VS:GetTileOffsetPoint | VS:SetTileOffsetPoint

VS Functions:

[[VS:CreateTile]] | [[VS:ShowEditTileDialog]] | [[VS:ShowEditTileSettingsDialog]] | [[VS:ShowNewTileDialog]] | [[VS:GetTileGeometryGroup]] | [[VS:BeginGroupN]] | [[VS:AddTileGeometryObject]] | [[VS:GetTileGroupParent]] | [[VS:IsTileGroupContainedObject]] | [[VS:GetTileBackgroundColor]] | [[VS:SetTileBackgroundColor]] | [[VS:GetTileRepetitionPoint]] | [[VS:SetTileRepetitionPoint]] | [[VS:GetTileOffsetPoint]]

| [[VS:SetTileOffsetPoint]]