VS:AddSubMtrlToMtrl

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds a Simple material to a Compound material. Sets the fraction of the Simple material as a relation to the whole. Fraction can have value between 0.0 and 1.0. "Primary" material is a simple material which carries the graphical attributes to be used by the compound material.

FUNCTION AddSubMtrlToMtrl(
hMaterial :HANDLE;
subMtrlName :STRING;
fraction :REAL;
makePrimary :BOOLEAN) : Boolean;
def vs.AddSubMtrlToMtrl(hMaterial, subMtrlName, fraction, makePrimary):
    return Boolean

Parameters

hMaterial HANDLE Handle of a Compound material
subMtrlName STRING Name of a Simple material to be added
fraction REAL Fraction of the Simple material
makePrimary BOOLEAN True if this Simple material should become the primary material of the Compound material

Return Value

Returns true if successful; false otherwise. Function fails if the simple material already was added.

Version

Availability: from Vectorworks 2021