VS:AddRadioMode

From Vectorworks Developer
Revision as of 16:07, 20 October 2014 by Jbenghiat (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds a group of buttons with an image to the mode bar for a tool. Replaces vstAddRadioMode

PROCEDURE AddRadioMode(
initialSetting :INTEGER;
buttonCount :INTEGER;
imageSpecifier1 :DYNARRAY[] of CHAR;
imageSpecifier2 :DYNARRAY[] of CHAR;
imageSpecifier3 :DYNARRAY[] of CHAR;
imageSpecifier4 :DYNARRAY[] of CHAR;
imageSpecifier5 :DYNARRAY[] of CHAR;
imageSpecifier :DYNARRAY[] of CHAR);
def vs.AddRadioMode(initialSetting, buttonCount, imageSpecifier1, imageSpecifier2, imageSpecifier3, imageSpecifier4, imageSpecifier5, imageSpecifier):
    return None

Parameters

initialSetting INTEGER
buttonCount INTEGER
imageSpecifier1 DYNARRAY[] of CHAR The string identifier for the image. It should be of the form "ResourceFileNameWithoutExtension/PathOfImageFile".
imageSpecifier2 DYNARRAY[] of CHAR The string identifier for the image. It should be of the form "ResourceFileNameWithoutExtension/PathOfImageFile".
imageSpecifier3 DYNARRAY[] of CHAR The string identifier for the image. It should be of the form "ResourceFileNameWithoutExtension/PathOfImageFile".
imageSpecifier4 DYNARRAY[] of CHAR The string identifier for the image. It should be of the form "ResourceFileNameWithoutExtension/PathOfImageFile".
imageSpecifier5 DYNARRAY[] of CHAR The string identifier for the image. It should be of the form "ResourceFileNameWithoutExtension/PathOfImageFile".
imageSpecifier DYNARRAY[] of CHAR The string identifier for the image. It should be of the form "ResourceFileNameWithoutExtension/PathOfImageFile".

Version

Availability: from Vectorworks 2012