VS:AddObjectTo2DComp

From Vectorworks Developer
Revision as of 22:36, 12 September 2018 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds an object to the specified 2D component group of a symbol definition or plug-in object. Use Top/Plan if you want to add the the object into the main container of the symbol definition or plug-in object.


Table - 2D components
2D component Constant
Not Set 0
Top 1
Bottom 2
Top and Bottom Cut 3
Front 4
Back 5
Front and Back Cut 6
Left 7
Right 8
Left and Right Cut 9
Top/Plan 10

FUNCTION AddObjectTo2DComp(
objectHandle :HANDLE;
objToAddHandle :HANDLE;
component :INTEGER) : BOOLEAN;
def vs.AddObjectTo2DComp(objectHandle, objToAddHandle, component):
    return BOOLEAN

Parameters

objectHandle HANDLE Symbol definition or plug-in object.
objToAddHandle HANDLE New object to be added to the 2D component group.
component INTEGER 2D component

Return Value

Returns TRUE if the operation was successful.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:Set2DComponentGroup | VS:Get2DComponentGroup

VS Functions:

[[VS:Set2DComponentGroup]]

| [[VS:Get2DComponentGroup]]