VS:AddGroupBox

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds a group box to a custom dialog.

Group Box Dialog Control:

Group Box Dialog Control

PROCEDURE AddGroupBox(
s :STRING;
item :INTEGER;
left :INTEGER;
top :INTEGER;
right :INTEGER;
bottom :INTEGER);
def vs.AddGroupBox(s, item, left, top, right, bottom):
    return None

Parameters

s STRING Group box title string.
item INTEGER Dialog item ID value.
left INTEGER Top left X coordinate of group box bounds in dialog.
top INTEGER Top left Y coordinate of group box bounds in dialog.
right INTEGER Bottom right X coordinate of group box bounds in dialog.
bottom INTEGER Bottom right Y coordinate of group box bounds in dialog.

Remarks

Note: deprecated from VW 9+: use CreateGroupBox, CreateCheckBoxGroupBox, CreateRadioButtonGroupBox

Adds a group box to a dialog. Specify the group title, item ID, and the location of the box.

Example

VectorScript

AddField('Find:',3,1,16,10,95,36);
AddField('',4,2,20,30,305,46);
AddField('Replace with:',5,1,16,59,113,75);
AddField('',6,2,20,80,305,96);
AddGroupBox('Options',7,20,110,305,250);	
AddChoiceItem('Text Options',8,1,27,135,152,145);
AddChoiceItem('Layer Options',9,1,27,165,152,175);

Python


Version

Availability: from VectorWorks 8.0. Deprecated from VW 9.