VS:AddField/ja

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

カスタムダイアログに編集可能/不可能なテキストフィールドを作成します。


注:編集可能なテキストフィールド1行の高さは16ピクセルにしてください。

PROCEDURE AddField(
fieldStr :STRING;
itemID :INTEGER;
fieldType :INTEGER;
x1 :INTEGER;
y1 :INTEGER;
x2 :INTEGER;
y2 :INTEGER);
def vs.AddField(fieldStr, itemID, fieldType, x1, y1, x2, y2):
    return None

Parameters

fieldStr STRING フィールドの文字列
itemID INTEGER フィールドアイテム番号
fieldType INTEGER フィールドの種類
x1 INTEGER フィールドの左上のX座標
y1 INTEGER フィールドの左上のY座標
x2 INTEGER フィールドの右下のX座標
y2 INTEGER フィールドの右下のY座標

Example

AddField('Enter number:',4,1,35,64,115,80);

Version

AddField 廃止バージョン: Vectorworks 2010


利用可能バージョン: MiniCAD