VS:AddField

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Defines a static or editable text field within the custom dialog definition. Note: single line edit fields should be 16 pixels high.

Note: Static and editiable text fields can be activated or deactivated using VS:SetItemEnable().

Table - Field Types
Button Style
Static Text Field 1
Editable Text Field 2

Text Field Types:

Text Field Types

PROCEDURE AddField(
fieldStr :STRING;
itemID :INTEGER;
fieldType :INTEGER;
x1 :INTEGER;
y1 :INTEGER;
x2 :INTEGER;
y2 :INTEGER);
def vs.AddField(fieldStr, itemID, fieldType, x1, y1, x2, y2):
    return None

Parameters

fieldStr STRING The descriptive text for the field item.
itemID INTEGER Unique item ID for the dialog field, in a range of 1-50.
fieldType INTEGER The type of field item to be displayed.
x1 INTEGER Top left X coordinate of field item bounding box.
y1 INTEGER Top left Y coordinate of field item bounding box.
x2 INTEGER Bottom right X coordinate of field item bounding box
y2 INTEGER Bottom right Y coordinate of field item bounding box.

Remarks

Note: deprecated from VW 9+: use CreateStaticText, CreateEditText, CreateEditTextBox, CreateEditInteger, CreateEditReal

Example

VectorScript

AddField('Enter number:', 4, 1, 35, 64, 115, 80);

Python


Version

Availability: from All Versions. Deprecated from VW 9.