VS:AddCustomTexPart

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

Description

PROCEDURE AddCustomTexPart(
obj :HANDLE;
partID :LONGINT;
partName :STRING);
def vs.AddCustomTexPart(obj, partID, partName):
    return None

Parameters

obj HANDLE The object to add a custom texture part to.
partID LONGINT The texture part ID. Start at 100 to avoid conflicts with existing texture parts.
partName STRING The texture part name, which will be shown in the texturing UI.

Example

RemoveCustomTexParts(h);
AddCustomTexPart(h, 100, ‘Stringers’);
AddCustomTexPart(h, 200, ‘Treads’);

Version

Available version: Vectorworks 2017