VS:AddCustomTexPart: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 1: Line 1:


{{LocationMain|category=LocationVS/|specific=}}
__TOC__
<vwDoc>
-----------------------------------------------------------------------------------------------------------
<desc>
This procedure adds a custom texture part with the specified ID and name to the object. Use partID starting at 100 to avoid conflicts with existing texture parts.
-----------------------------------------------------------------------------------------------------------
<def>
<funcDef lang="vs">
PROCEDURE AddCustomTexPart(obj:HANDLE; partID:LONGINT; partName:STRING);
</funcDef>
<funcDef lang="py">
def vs.AddCustomTexPart(obj, partID, partName):
    return None
</funcDef>
</def>
-----------------------------------------------------------------------------------------------------------
<params>
<lineList ident=1>
<line>
obj
HANDLE
The object to add a custom texture part to.
</line>
<line>
partID
LONGINT
The texture part ID. Start at 100 to avoid conflicts with existing texture parts.
</line>
<line>
partName
STRING
The texture part name, which will be shown in the texturing UI.
</line>
</lineList>
</params>
-----------------------------------------------------------------------------------------------------------
<remark></remark>
-----------------------------------------------------------------------------------------------------------
<sample>
<code lang='vs'>
RemoveCustomTexParts(h);
AddCustomTexPart(h, 100, ‘Stringers’);
AddCustomTexPart(h, 200, ‘Treads’);
</code>
</sample>
-----------------------------------------------------------------------------------------------------------
<seeAlso></seeAlso>
-----------------------------------------------------------------------------------------------------------
<version>
Available version: Vectorworks 2017
</version>
</vwDoc>
[[Category:VS Function Reference|AddCustomTexPart]]
[[Category:VS Function Reference:Textures|AddCustomTexPart]]

Latest revision as of 19:26, 25 January 2018

Description

PROCEDURE AddCustomTexPart(
obj :HANDLE;
partID :LONGINT;
partName :STRING);
def vs.AddCustomTexPart(obj, partID, partName):
    return None

Parameters

obj HANDLE The object to add a custom texture part to.
partID LONGINT The texture part ID. Start at 100 to avoid conflicts with existing texture parts.
partName STRING The texture part name, which will be shown in the texturing UI.

Example

RemoveCustomTexParts(h);
AddCustomTexPart(h, 100, ‘Stringers’);
AddCustomTexPart(h, 200, ‘Treads’);

Version

Available version: Vectorworks 2017