VS:AddCavity/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

壁に中心線を追加します。


ビットマップは0から71までの正の値で示されています。ハッチングは負の値で示されています。

PROCEDURE AddCavity(
pair :BOOLEAN;
leftOffDistance :REAL)Coordinate); rightOffDistance:REAL (Coordinate); pairFill:LONGINT);
def vs.AddCavity(pair, leftOffDistance, rightOffDistance, pairFill):
    return None

Parameters

pair BOOLEAN 二重線の場合はTRUE
leftOffDistance REAL (Coordinate) 右側のオフセット値
rightOffDistance REAL (Coordinate) 左側のオフセット値
pairFill LONGINT 模様番号

Example

{ Create wall object with 1" wide cavity using black pattern fill.}
DoubLines(6");
AddCavity(True, 1", 2", 2);
Wall(0, 1, 9, 1);

{ Create wall object with 1" wide cavity using a custom hatch fill.}
DoubLines(6");
AddCavity(True, 1", 2", -Name2Index('My Hatch'));
Wall(0, 1, 9, 1);

Version

AddCavity 廃止バージョン: VectorWorks12.0


利用可能バージョン: MiniCAD4.0