VS:AddCavity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 55: Line 55:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample>
{{AddCavity_DoubLines_Wall.doc}}
{{{{file}}:AddCavity DoubLines Wall.doc}}
</sample>
</sample>



Revision as of 18:25, 23 June 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure AddCavity creates a wall cavity in a new wall object. The newly defined cavity becomes the default for all subsequently defined walls.

To apply a bitmap fill pattern, use positive value corresponding to the index of the bitmap pattern. To apply a vector fill pattern, use the negative of the vector fill index (index * -1).

Fill patterns and their associated constants can be found in the [[VS:Function Reference Appendix#[edit] Fill Patterns|VectorScript Appendix]].

PROCEDURE AddCavity(
pair :BOOLEAN;
leftOffDistance :REAL;
rightOffDistance :REAL;
pairFill :LONGINT);
def vs.AddCavity(pair, leftOffDistance, rightOffDistance, pairFill):
    return None

Parameters

pair BOOLEAN Double line display mode.
leftOffDistance REAL Left edge offset from wall centerline.
rightOffDistance REAL Right edge offset from wall centerline.
pairFill LONGINT Fill index for filled cavities.

Remarks

OBSOLETE for Version 12: This function is obsolete. Use InsertNewComponent instead. (NZH 5-9-05)

Example

{{Template:File:AddCavity DoubLines Wall.doc}}

Version

AddCavity is obsolete as of VectorWorks12.0


Availability: from MiniCAD4.0