VS:AddCavity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(add see also)
 
Line 9: Line 9:
To apply a bitmap fill pattern, use positive value corresponding to the index  of the bitmap pattern.  To apply a vector fill pattern, use the negative of the vector fill index (index * -1).  
To apply a bitmap fill pattern, use positive value corresponding to the index  of the bitmap pattern.  To apply a vector fill pattern, use the negative of the vector fill index (index * -1).  


Fill patterns and their associated constants can be found in the [[VS:Function Reference Appendix#[edit] Fill Patterns|VectorScript Appendix]].
Fill patterns and their associated constants can be found in the [[VS:Function Reference Appendix#Fill Patterns|VectorScript Appendix]].
</desc>
</desc>


Line 51: Line 51:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
OBSOLETE for Version 12: This function is obsolete. Use InsertNewComponent instead. (NZH 5-9-05)</remark>
(NZH 5-9-05) OBSOLETE for Version 12: Use [[VS:InsertNewComponent]] instead.  
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 60: Line 61:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
AddCavity is obsolete as of VectorWorks12.0<P>
AddCavity is obsolete as of VectorWorks 12.0.


Availability: from MiniCAD 4.0


Availability: from MiniCAD4.0
</version>


</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
VS Functions:
[[VS:InsertNewComponent | InsertNewComponent]]
</seeAlso>


</vwDoc>
</vwDoc>

Latest revision as of 03:16, 17 June 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure AddCavity creates a wall cavity in a new wall object. The newly defined cavity becomes the default for all subsequently defined walls.

To apply a bitmap fill pattern, use positive value corresponding to the index of the bitmap pattern. To apply a vector fill pattern, use the negative of the vector fill index (index * -1).

Fill patterns and their associated constants can be found in the VectorScript Appendix.

PROCEDURE AddCavity(
pair :BOOLEAN;
leftOffDistance :REAL;
rightOffDistance :REAL;
pairFill :LONGINT);
def vs.AddCavity(pair, leftOffDistance, rightOffDistance, pairFill):
    return None

Parameters

pair BOOLEAN Double line display mode.
leftOffDistance REAL Left edge offset from wall centerline.
rightOffDistance REAL Right edge offset from wall centerline.
pairFill LONGINT Fill index for filled cavities.

Remarks

(NZH 5-9-05) OBSOLETE for Version 12: Use VS:InsertNewComponent instead.

Example

VectorScript

{ Create wall object with 1" wide cavity using black pattern fill.}
DoubLines(6");
AddCavity(True, 1", 2", 2);
Wall(0, 1, 9, 1);

{ Create wall object with 1" wide cavity using a custom hatch fill.}
DoubLines(6");
AddCavity(True, 1", 2", -Name2Index('My Hatch'));
Wall(0, 1, 9, 1);

Python

#{ Create wall object with 1" wide cavity using black pattern fill.}
vs.DoubLines(6)
vs.AddCavity(1, 1, 2, 2)
vs.Wall(0, 1, 9, 1)

#{ Create wall object with 1" wide cavity using a custom hatch fill.}
vs.DoubLines(6)
vs.AddCavity(1, 1, 2, -vs.Name2Index('My Hatch'))
vs.Wall(0, 1, 9, 1)

Version

AddCavity is obsolete as of VectorWorks 12.0.

Availability: from MiniCAD 4.0

See Also

VS Functions:

InsertNewComponent

VS Functions: [[VS:InsertNewComponent | InsertNewComponent]]