VS:AddButton/ja: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:25, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

カスタムダイアログにボタン(OK、キャンセルボタン、チェックボックス、ラジオボタンなど)を作成します。

PROCEDURE AddButton(
buttonStr :STRING;
itemID :INTEGER;
buttonType :INTEGER;
x1 :INTEGER;
y1 :INTEGER;
x2 :INTEGER;
y2 :INTEGER);
def vs.AddButton(buttonStr, itemID, buttonType, x1, y1, x2, y2):
    return None

Parameters

buttonStr STRING ボタンの文字列
itemID INTEGER ボタンアイテム番号
buttonType INTEGER ボタンの種類
x1 INTEGER ボタンの左上のX座標
y1 INTEGER ボタンの左上のY座標
x2 INTEGER ボタンの右下のX座標
y2 INTEGER ボタンの右下のY座標

Example

{creates a check box }
AddButton('Use Sound',4,3,25,60,125,80);

{creates a push button that is the default button of the dialog }
AddButton('OK',1,1,25,60,125,80);

Version

AddButton 廃止バージョン: Vectorworks 2010


利用可能バージョン: MiniCAD

See Also

関連関数:

VS:SetItemEnable

関連関数: [[VS:SetItemEnable]]