VS:ActSymDefN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:48, 16 September 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function ActSymDefN returns a handle to the currently active symbol.


If the active symbol is not in the active document, it will be imported, unless there is a conflict and the allowConflictDlg parameter is set to FALSE. After being imported, the imported symbol will be returned.

FUNCTION ActSymDefN(
allowConflictDlg :BOOLEAN) : HANDLE;
def vs.ActSymDefN(allowConflictDlg):
    return HANDLE

Parameters

allowConflictDlg BOOLEAN Whether to show a conflict dialog if the active symbol is not in the active document, and a conflict would need to be resolved to import it. If there is a conflict and allowConflictDlg is set to FALSE, ActSymDefN will return NULL.

Example

HandleToActiveSym:=ActSymDefN(TRUE);

Version

Availability: from Vectorworks 2021

See Also

VS Functions:

VS:ActLayer | VS:ActiveClass | VS:ActSymDef

VS Functions:

[[VS:ActLayer]] | [[VS:ActiveClass]]

| [[VS:ActSymDef]]