VS:SetStoryElevationN

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the elevation of the indicated Story. Returns whether the elevation was successfully set. If the elevaton change would cause Layers associated with the Story to overlap Layers associated with another Story, then the change in elevation will be prevented.

FUNCTION SetStoryElevationN(
story :HANDLE;
elevation :REAL) : BOOLEAN;
def vs.SetStoryElevationN(story, elevation):
    return BOOLEAN

Parameters

story HANDLE The Story whose elevation is to be set.
elevation REAL The elevation to set the Story to. The elevation is in document units.

Return Value

Whether the elevation is successfully changed.

Version

Availability: from Vectorworks 2025

See Also

VS Functions:

VS:CreateStory | VS:GetStoryElevationN

VS Functions:

[[VS:CreateStory]]

| [[VS:GetStoryElevationN]]