VS:SetLevelElevationN

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the elevation of a Story Level relative to its Story.

FUNCTION SetLevelElevationN(
storyHandle :HANDLE;
levelType :STRING;
newElevation :REAL) : BOOLEAN;
def vs.SetLevelElevationN(storyHandle, levelType, newElevation):
    return BOOLEAN

Parameters

storyHandle HANDLE The handle of the Story with the desired Story Level.
levelType STRING The level type of the Story Level to change the elevation of.
newElevation REAL The new elevation for the Story Level. The elevation is in document units.

Return Value

Whether the Story Level was found and successfully updated.

Version

Availability: from Vectorworks 2025

See Also

VS Functions:

VS:CreateStory | VS:AddStoryLevelN | VS:RemoveStoryLevel | VS:AddLevelFromTemplate | VS:GetLevelElevationN

VS Functions:

[[VS:CreateStory]] | [[VS:AddStoryLevelN]] | [[VS:RemoveStoryLevel]] | [[VS:AddLevelFromTemplate]]

| [[VS:GetLevelElevationN]]