VS:IFC DefPsetImport2

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Imports Custom Object Presets from XML, XLSX, CSV or text files.

If parameter is empty, Import File dialog is shown to select the desired file.

FUNCTION IFC_DefPsetImport2(
strFilePath :STRING) : BOOLEAN;
def vs.IFC_DefPsetImport2(strFilePath):
    return BOOLEAN

Parameters

strFilePath STRING The path to the file. If param is empty, Import File dialog is shown to select the desired file.

Example

PROCEDURE PsetImport;
VAR
        bOK : BOOLEAN
BEGIN
        {We suggest that we are importing from an Presets.xml file that is located on D:\Vectorworks\Presets.xml}
	bOK := IFC_DefPsetImport2( 'D:\Vectorworks\Presets.xml');
END;

RUN(PsetImport);

Python

# We suggest that we are importing from an Presets.xml file that is located on D:\Vectorworks\Presets.xml
ok = vs.IFC_DefPsetImport2( 'D:\Vectorworks\Presets.xml');

Version

Availability: from Vectorworks 2023 SP6