VS:GetModifierFlags

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the state of option/alt, cmd/ctrl, shift keys.

PROCEDURE GetModifierFlags(
VAR optionFlag :BOOLEAN;
VAR cmdFlag :BOOLEAN;
VAR shiftFlag :BOOLEAN);
def vs.GetModifierFlags():
    return (optionFlag, cmdFlag, shiftFlag)

Parameters

optionFlag BOOLEAN The state of the option/alt key.
cmdFlag BOOLEAN The state of the cmd/ctrl key.
shiftFlag BOOLEAN The state of the shift key.

Return Value

Returns the state of option/alt, cmd/ctrl, shift keys.

Version

Availability: from Vectorworks 2025