VCOM:VectorWorks:UI:IInfoBar::IncrementProgressIndicator: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(New page: __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <desc> namespace <code>VectorWorks::UI</code> Member of [[VCOM...)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:07, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::UI

Member of VCOM:VectorWorks:UI:IInfoBar

Moves the progress indicator with the specified amount.

virtual VCOMError VCOM_CALLTYPE IncrementProgressIndicator(
Uint16 nProgress) = 0;
virtual VCOMError VCOM_CALLTYPE IncrementProgressIndicator(
Uint16 nProgress,
const TXString& strProgressLabel) = 0;

Parameters

nProgress Uint16 Increment the progress indicator with this value.
strProgressLabel const TXString& The new progress label text.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.