VCOM:VectorWorks:UI:IColorMenu

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::UI

Interface

// {5f616ed0-7b07-11db-9fe1-0800200c9a66}
//
static const VWIID IID_ColorMenu = { 0x5f616ed0, 0x7b07, 0x11db, { 0x9f, 0xe1, 0x08, 0x00, 0x20, 0x0c, 0x9a, 0x66 } };
		
class IColorMenu : public IVWUnknown
{
public:
  virtual VCOMError VCOM_CALLTYPE ColorPopupMenuSelect(
                                    ViewRect& inParentBounds,
                                    ViewRect& inDisplayBounds,
                                    EColorMenuFlavor inMenuFlavor,
                                    IDocumentColorTable* pColorTableAPI, 
                                    ColorRef& ioColorRef,
                                    bool& outColorByClass ) = 0;
};

Members

ColorPopupMenuSelect no info

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IColorMenu interface:

typedef VCOMPtr<IColorMenu>  IColorMenuPtr;
enum EColorMenuFlavor
{
  eColorMenuFlavor_ColorOnly,
  eColorMenuFlavor_ColorWithByClassOption
};

Version

Available from: VectorWorks 12

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]