VCOM:VectorWorks:Scripting:IPythonWrapper::Call: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:Scripting:IPythonWrapper]]
Member of [[VCOM:VectorWorks:Scripting:IPythonWrapper]]


...put some description here...
Execute a function already present in the run-time.
</desc>
</desc>


Line 25: Line 25:
<params>
<params>
<lineList ident=1>
<lineList ident=1>
<line>
moduleName
const char*
Module name that contains the function
</line>
<line>
<line>
functionName
functionName
const char*
const char*
no info.
The function name to execute;
</line>
</line>
<line>
<line>
arrParams
arrParams
const TXStringArray&
const TXStringArray&
no info.
Parameters for the call.
</line>
</line>
</lineList>
</lineList>

Revision as of 17:42, 19 September 2013

Description

namespace VectorWorks::Scripting

Member of VCOM:VectorWorks:Scripting:IPythonWrapper

Execute a function already present in the run-time.

virtual bool VCOM_CALLTYPE Call(
const char* functionName,
const TXStringArray& arrParams) = 0;
virtual bool VCOM_CALLTYPE Call(
const char* moduleName,
const char* functionName,
const TXStringArray& arrParams) = 0;

Parameters

moduleName const char* Module name that contains the function
functionName const char* The function name to execute;
arrParams const TXStringArray& Parameters for the call.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Version

Availability: from Vectorworks 2014