VCOM:VectorWorks:Scripting:IPythonWrapper::AddPath: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:Scripting:IPythonWrapper]]
Member of [[VCOM:VectorWorks:Scripting:IPythonWrapper]]


...put some description here...
Add search path for python modules in this run-time. This is equivalent of python's sys.path variable.
</desc>
</desc>


Line 25: Line 25:
path
path
const char*
const char*
no info.
OS dependent path.
</line>
</line>
</lineList>
</lineList>

Latest revision as of 17:29, 19 September 2013

Description

namespace VectorWorks::Scripting

Member of VCOM:VectorWorks:Scripting:IPythonWrapper

Add search path for python modules in this run-time. This is equivalent of python's sys.path variable.

virtual voidVCOM_CALLTYPE AddPath(
const char* path) = 0;

Parameters

path const char* OS dependent path.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Version

Availability: from Vectorworks 2014