VCOM:VectorWorks:PluginSupport:IExtendedProps::SetObjComponentTypeDefLineWeight: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(New page: __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <desc> namespace <code>VectorWorks::PluginSupport</code> Membe...)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:07, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::PluginSupport

Member of VCOM:VectorWorks:PluginSupport:IExtendedProps

No info.

virtual VCOMError VCOM_CALLTYPE SetObjComponentTypeDefLineWeight(
CodeRefID inCodeRefID,
TComponentTypeID typeID,
Sint16 lineWeight,
bool bByClass) = 0;

Parameters

inCodeRefID CodeRefID
typeID TComponentTypeID
lineWeight Sint16
bByClass bool

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.