VCOM:VectorWorks:IToolInteractiveDraw::RemoveObject

From Vectorworks Developer
Revision as of 15:07, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:IToolInteractiveDraw. Removes the interactive object of the given object type and id if it exists.

virtual voidVCOM_CALLTYPE RemoveObject(
short objType,
Sint32 id = 0) = 0;

Parameters

objType short no info.
id Sint32 no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.