VCOM:VectorWorks:ISDK::StringToDouble

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Parses the inString based on inNumStyle, performs any math operations, and returns a real value in outDouble. Returns false if there is an error in parsing the string.

virtual bool StringToDouble(
TNumStyleClass inNumStyle,
const TXString& inString,
double_gs& outDouble)

Parameters

TNumStyleClass inNumStyle No information available.
constTXString& inString No information available.
double_gs& outDouble No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009