VCOM:VectorWorks:ISDK::StringToAngleN

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Convert between an angle string and a number of degrees. StringToAngle will accept degrees, minutes, and seconds or decimal degrees (or no explicit angle units; this is presumed to be degrees).

virtual bool StringToAngleN(
const TXString& s,
double_gs& angle)

Parameters

constTXString& s No information available.
double_gs& angle No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009