VCOM:VectorWorks:ISDK::SetSavedSetting

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Writes a value to the saved settings file.

virtual void SetSavedSetting(
const TXString& category,
const TXString& setting,
const TXString& value)

Parameters

const TXString& category A category name for the setting to be stored.
const TXString& setting The name of the setting to be stored.
const TXString& value The value of the setting to be stored.

Remarks

The values are stored in an XML file. A "/" in "category" can be used as a hierarchy separator to store values in a structured way.

Version

Availability: from Vectorworks 2009


See also

GetSavedSetting