VCOM:VectorWorks:ISDK::SetPersistentHighlight

From Vectorworks Developer
Revision as of 15:07, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

SetPersistentHighlight is the interface for a global persistent object highlighting system which allows a single object to be highlighted in a manner similar to, but more transient than object selection. When highlighted by calling this function with a true value in hilightState, the object will be drawn in or surrounded by a bold pen stroke. If an object is highlighted using this call and the drawing is refreshed for any reason, the highlight state will be properly maintained until it is eventually removed by calling this function again with a false value passed in hilightState. A plug-in must remove any hilight state it applies to an object before it returns control to VectorWorks.

virtual void SetPersistentHighlight(
MCObjectHandle theObject,
bool highlightState)

Parameters

MCObjectHandle theObject No information available.
bool highlightState No information available.

Version

Availability: from Vectorworks 2009