VCOM:VectorWorks:ISDK::SetComponentFill

From Vectorworks Developer
Revision as of 15:05, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the fill of a component in an object.

virtual Boolean VCOM_CALLTYPE SetComponentFill(
MCObjectHandle object,
short componentIndex,
long fill) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex short The index of the component.
fill long The fill of the component. Positive values for patterns, negative object indexes for hatches.

Version

Availability: from Vectorworks 2009