VCOM:VectorWorks:ISDK::SearchForAncestorType: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:05, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

For object h, returns the first ancestor object of type tdType, or nil if no (eventual) parent of that type exists. For example, CB_SearchForAncestorType(16, h) will return the symDef that contains h, or nil if h is not a child of a symDef. Aux lists are not considered in this function (if h is in an aux list, this function will always return nil).

virtual MCObjectHandle SearchForAncestorType(
Sint16 objectType,
MCObjectHandle h)

Parameters

Sint16 objectType No information available.
MCObjectHandle h No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009