VCOM:VectorWorks:ISDK::PlaceSymbolByNameN

From Vectorworks Developer
Revision as of 15:05, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Places an instance of the the symbol with the given name at the specified location, rotated by <rotation> degrees. If there is no symbol with the specified name, PlaceSymbolByName does nothing.

virtual MCObjectHandle PlaceSymbolByNameN(
const InternalName symName,
const WorldPt& location,
double_param rotation = 0.0)

Parameters

const InternalName symName No information available.
const WorldPt& location No information available.
double_param rotation=0.0 No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009