VCOM:VectorWorks:ISDK::PlaceSymbolByNameN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
mNo edit summary
 
Line 51: Line 51:
</version>
</version>


<remark>
Be aware that you have to add the handle to the drawing list after this call. In VWFC use:
        VWPoint2D testpt(0, 0);
        VWSymbolObj mysym(TXString("my symdef name"), testpt);
        VWLayerObj currLayer( VWLayerObj::GetCurrentLayer() );
        currLayer.AddObject( mysym );
</remark>
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:ISDK|PlaceSymbolByNameN]]
[[Category:VCOM:VectorWorks:ISDK|PlaceSymbolByNameN]]
[[Category:VCOM:VectorWorks:ISDK(Creation)|PlaceSymbolByNameN]]
[[Category:VCOM:VectorWorks:ISDK(Creation)|PlaceSymbolByNameN]]

Latest revision as of 05:41, 12 September 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Places an instance of the the symbol with the given name at the specified location, rotated by <rotation> degrees. If there is no symbol with the specified name, PlaceSymbolByName does nothing.

PlaceSymbolByNameN creates the symbol but does not insert it into the document.

virtual MCObjectHandle PlaceSymbolByNameN(
const InternalName symName,
const WorldPt& location,
double_param rotation = 0.0)

Parameters

const InternalName symName No information available.
const WorldPt& location No information available.
double_param rotation=0.0 No information available.

Return Value

On error returns: nil

Remarks

Be aware that you have to add the handle to the drawing list after this call. In VWFC use:

       VWPoint2D testpt(0, 0);
       VWSymbolObj mysym(TXString("my symdef name"), testpt);
       VWLayerObj currLayer( VWLayerObj::GetCurrentLayer() );
       currLayer.AddObject( mysym );

Version

Availability: from Vectorworks 2009