VCOM:VectorWorks:ISDK::LineEllipseIntersect

From Vectorworks Developer
Revision as of 15:05, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Calculates the intersection between the two lines specified. Parallel is set if no intersection could be found because the lines are parallel. intOnLine is set if the intersection is between the endpoints of both lines.

virtual void LineEllipseIntersect(
const WorldPt& a1,
const WorldPt& a2,
const WorldRect& r,
Sect2Struct& sects)

Parameters

constWorldPt& a1 No information available.
constWorldPt& a2 No information available.
constWorldRect& r No information available.
Sect2Struct& sects No information available.

Version

Availability: from Vectorworks 2009