VCOM:VectorWorks:ISDK::IntersectSolid

From Vectorworks Developer
Revision as of 07:20, 29 August 2013 by Maarten (talk | contribs) (Result was incorrect, error does not return 0 but one of the other codes. Succes returns 0! Added some extra info.)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Will create a new solid that is the intersection of two solids (Obj1 and Obj2).

  • Obj1 and Obj2 will be removed on succes.
  • Obj1 and Obj2 needs to be solids, 3D polylines will return 20 (Bad input).
virtual short IntersectSolid(
MCObjectHandle obj1,
MCObjectHandle obj2,
MCObjectHandle& newSolid)

Parameters

MCObjectHandle obj1 The first solid.
MCObjectHandle obj2 The second solid.
MCObjectHandle& newSolid The intersection result.

Return Value

Operation Result Result Code
Success 0
Null geometry error 1
Geometry error 2
Out of memory error 4
Bad group error 5
Invalid object type 6
Bad input 20

Version

Availability: from Vectorworks 2009