VCOM:VectorWorks:ISDK::IntersectObjects

From Vectorworks Developer
Revision as of 20:47, 13 August 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns a handle of CoordPts which indicate all of the intersections between the two objects. If onlyOnObjs is true, then only intersections that actually lie on both objects are returned. The returned intersection handle must be disposed after using.

virtual MCObjectHandle IntersectObjects(
MCObjectHandle obj1,
MCObjectHandle obj2,
bool onlyOnObjs)

Parameters

MCObjectHandle obj1 No information available.
MCObjectHandle obj2 No information available.
bool onlyOnObjs No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009