VCOM:VectorWorks:ISDK::InsertWidget: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:05, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Inserts an existing parameter into the Object Info Palette for event-enabled plug-in objects. position is the 0-based position for this new widget. WidgetType values: 12 (button), 13 (static text). EventID is data included in widget-generated event.

virtual bool InsertWidget(
long ObjectID,
int position,
int widgetType,
int eventID,
const TXString& text,
long data)

Parameters

long ObjectID No information available.
int position No information available.
int widgetType No information available.
int eventID No information available.
constTXString& text No information available.
long data No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009