VCOM:VectorWorks:ISDK::GetProduct

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Retrieves information that identifies what vertical market product (if any) is currently running, and which add-ons (modules) are currently available (if any).

virtual void GetProduct(
short& product,
long& modules)

Parameters

short& product No information available.
long& modules No information available.

Remarks

kProductVWBasic            = 0x00000000,
kProductRWBasic            = 0x00000001,
kProductVWArchitect        = 0x00000002,
kProductVWLandmark         = 0x00000004,
kProductVWSpotlight        = 0x00000008,
kProductVWEngineer         = 0x00000010,
kProductVWEurope           = 0x00000020

Version

Availability: from Vectorworks 2009