VCOM:VectorWorks:ISDK::GetMesh

From Vectorworks Developer
Revision as of 03:47, 4 March 2022 by Listenwind (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

Description

namespace

Member of VCOM:VectorWorks:ISDK

GetMesh only works for kMeshNode objects. It doesn't work for solids.

virtual bool VCOM_CALLTYPE GetMesh(
MCObjectHandle hMesh,
IMeshData** outMeshData) = 0;

Parameters

hMesh MCObjectHandle A handle of kMeshNode objects
outMeshData IMeshData** no info.

Example

// meshH is a handle of kMeshNode objects
Handle meshH;

...

VectorWorks::IMeshDataPtr	thisMesh;
bool isGetMesh = gSDK->GetMesh( meshH, & thisMesh );

Version

Availability: from Vectorworks 2015