VCOM:VectorWorks:ISDK::GetMesh: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:ISDK]]
Member of [[VCOM:VectorWorks:ISDK]]


...put some description here...
GetMesh only works for kMeshNode objects. It doesn't work for solids.
</desc>
</desc>


Line 25: Line 25:
hMesh
hMesh
MCObjectHandle
MCObjectHandle
no info.
A handle of kMeshNode objects
</line>
</line>
<line>
<line>
Line 45: Line 45:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample>
<code lang="cpp">
// meshH is a handle of kMeshNode objects
Handle meshH;
...
VectorWorks::IMeshDataPtr thisMesh;
bool isGetMesh = gSDK->GetMesh( meshH, & thisMesh );
</code>
</sample>
</sample>


Line 53: Line 62:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from Vectorworks 2015
Availability: from Vectorworks 2022


</version>
</version>

Revision as of 03:42, 4 March 2022

Description

namespace

Member of VCOM:VectorWorks:ISDK

GetMesh only works for kMeshNode objects. It doesn't work for solids.

virtual bool VCOM_CALLTYPE GetMesh(
MCObjectHandle hMesh,
IMeshData** outMeshData) = 0;

Parameters

hMesh MCObjectHandle A handle of kMeshNode objects
outMeshData IMeshData** no info.

Example

// meshH is a handle of kMeshNode objects
Handle meshH;

...

VectorWorks::IMeshDataPtr	thisMesh;
bool isGetMesh = gSDK->GetMesh( meshH, & thisMesh );

Version

Availability: from Vectorworks 2022